Card Maker won't load

Hi, I can’t get the card maker resource to load at all. I just get a spinning wheel forever. I’ve tried clearing cookies and using a different device, but it doesn’t solve the problem. Any suggestions?

Thanks for reporting, @Kristen_Bergh! I see the same bug. I’ll ask the developer to have a look.

Stand by,


Thanks for your patience, @Kristen_Bergh. Try it now? It may still take a moment to load, but the server is recovering.


It still doesn’t seem to be loading at all. I’ve left it going for several minutes.

oops, yes, so it was. Looks like our first problem was hiding a second problem. Try again now?

Thanks for your patience!

I am seeing the same issue!

hmm… The CardMaker page is not loading at all? It does take about 20 seconds for me, but it loaded just now.

Standing by,


It seems to be working for me now. Thank you for your help!

Excellent, thanks for your patience!

Hi sorry to reply to this thread again, but it seems that the card maker isn’t loading again today. I’m also getting the same issue with those who posted before. Thanks!